Cisco (e.g. 800)

This is a snippet of config and only an example, please expand/amend to suit your network requirements:

conf t

...

interface fa0/0
description Tibus
ip address dhcp
ip nat outside

interface fa0/1
description LAN
ip nat inside
ip address 192.168.1.1 255.255.255.0 

ip route 0.0.0.0 0.0.0.0 fa0/0
access-list 10 permit 192.168.1.0 0.0.0.255
ip nat inside source list 10 interface fa0/0 overload